BrainStorm platform down due to Microsoft encryption keys issue

Incident Report for BrainStorm

Postmortem

Summary
On Friday, March 20th, BrainStorm experienced a 30-minute service disruption due to a recurrence of a previously identified Microsoft-side encryption key issue first encountered on March 12.

Impact
The BrainStorm platform was unavailable from 7:02 AM to 7:32 AM MDT (30 minutes).

Root Cause
The outage was caused by an issue with Microsoft-managed encryption keys. During a redeployment of the account service, the encryption configuration reverted, triggering the same failure condition observed on March 12. This indicates the underlying issue on the Microsoft side has not yet been fully resolved.

Detection
Automated alerts were triggered immediately when the issue reoccurred, allowing for rapid identification of the problem.

Resolution
The team quickly identified the root cause and restored the correct encryption configuration. Service was fully restored within 30 minutes of the initial outage. Microsoft has been re-engaged and updated on the recurrence of this issue.

Preventive Actions / Next Steps

  • Updated encryption settings to “service managed” to prevent configuration reversion during future redeployments.
  • This configuration will remain in place until Microsoft provides a permanent fix.
  • Continued coordination with Microsoft support to track and resolve the underlying issue.
Posted Mar 23, 2026 - 11:36 MDT

Resolved

A recurrence of the issue we had on March 12th in which a Microsoft-side issue with encryption keys caused our platform to become unavailable.
Posted Mar 20, 2026 - 07:00 MDT