Some email communications being sent are blank

Incident Report for BrainStorm

Postmortem

Between May 21 and May 29, 2026, three (3) separate customers experienced instances where emails sent through BrainStorm Composer Email were delivered without content. Our investigation found that, in rare cases, an issue during the email publishing process caused an empty version of the email template to be saved and used for sending. We corrected the issue, implemented additional safeguards to prevent it from recurring, and verified that no published emails currently have this condition. These 3 affected customers successfully restored their emails by republishing their templates, and we continue to monitor the platform closely.   We apologize for the disruption and appreciate our customers' partnership as we resolved the issue.

Posted Jun 02, 2026 - 11:19 MDT

Resolved

This incident has been resolved.
Posted Jun 02, 2026 - 11:18 MDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 02, 2026 - 09:31 MDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 02, 2026 - 09:31 MDT

Investigating

We are currently investigating this issue. Please note that this is not happening on all communications but on a very few.
If you should experience this, please reach out to support@brainstorminc.com as we have a "work-a-round" to have the communication send correctly.
Posted May 29, 2026 - 08:55 MDT
This incident affected: BrainStorm Admin Portal (Communications/Notifications).