Service recovery across all AWS services continues to improve. We are contining to monitor all AWS systems that we use.
Posted Oct 20, 2025 - 14:31 MDT
Monitoring
AWS has taken additional mitigation steps to aid the recovery of the underlying issues and they are now seeing connectivity and API recovery for AWS services. We are continuing to monitor this recovery by AWS and will keep you updated.
Posted Oct 20, 2025 - 10:53 MDT
Identified
Due to the AWS outage, video playback, video upload, and dashboard updates may be affected. We are continuing to monitor this closely.
Posted Oct 20, 2025 - 08:52 MDT
Update
AWS is currently experiencing operational issue that has taken down major services. AWS team is working on mitigations. It might affect video uploading functionality on our platform. We are looking for an impact and potential issues it can cause.
Posted Oct 20, 2025 - 08:46 MDT
Investigating
We are currently investigating this issue.
Posted Oct 20, 2025 - 08:45 MDT
This incident affected: BrainStorm End-user Portal (Flow Progress, Content).