Dashboard data is not current or slow loading

Incident Report for BrainStorm

Resolved

This incident has been resolved.
Posted Dec 16, 2025 - 13:29 MST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 16, 2025 - 11:18 MST

Identified

This issue is related to an outage in our third-party data storage. We will provide updates as they are provided.
Posted Dec 16, 2025 - 08:58 MST
This incident affected: BrainStorm Admin Portal (Reporting).